enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / stopwatch / stopwatch_git.bb
1 DESCRIPTION = "Simple Qt based stop watch"
2 AUTHOR = "Christof Musik"
3 SECTION = "x11/applications"
4 PRIORITY = "optional"
5 HOMEPAGE = "http://git.senfdax.de"
6 LICENSE = "GPL QPL"
7 DEFAULT_PREFERRENCE = "-1"
8 PV = "1.3.1+gitr${SRCREV}"
9 PR = "r0"
10
11 inherit qt4x11
12
13 SRC_URI = "git://git.senfdax.de/git/stopwatch;protocol=http"
14 S = "${WORKDIR}/git/"
15
16 do_configure() {
17     ${OE_QMAKE_QMAKE}
18 }
19
20 do_compile() {
21     oe_runmake
22 }
23
24 do_install() {
25     install -d ${D}${bindir}
26     install -m 0755 ${S}stopwatch ${D}${bindir}
27     install -d ${D}${datadir}/applications
28     install ${S}desktop/stopwatch.desktop ${D}${datadir}/applications/
29     install -d ${D}${datadir}/pixmaps
30     install ${S}desktop/stopwatch.png ${D}${datadir}/pixmaps/
31     install -d ${D}${datadir}/${PN}
32     install ${S}desktop/om.style ${D}${datadir}/${PN}/
33 }