dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / ssmtp / ssmtp_2.61.bb
1 SECTION = "console/network"
2 DEPENDS = "openssl"
3 DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
4 LICENSE = "GPL"
5 PR = "r6"
6
7 SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
8            file://ldflags.patch;patch=1 \
9            file://configure.patch;patch=1 \
10            file://libs-lcrypto.patch;patch=1 \
11            file://dont-strip.patch;patch=1 \
12            file://ssmtp.conf"
13 S = "${WORKDIR}/${PN}-${PV}"
14
15 inherit autotools
16
17 CONFFILES_${PN} = "${sysconfdir}/ssmtp/ssmtp.conf ${sysconfdir}/ssmtp/revaliases"
18 EXTRA_OECONF = "--enable-ssl"
19 INHIBIT_AUTO_STAGE = "1"
20
21 do_compile () {
22         oe_runmake 'LDFLAGS=${LDFLAGS}'
23 }
24
25 do_install () {
26         oe_runmake 'prefix=${D}${prefix}' 'exec_prefix=${D}${exec_prefix}' \
27                    'bindir=${D}${bindir}' 'mandir=${D}${mandir}' \
28                    'etcdir=${D}${sysconfdir}' GEN_CONFIG="`which echo`" install
29         install -d ${D}${sysconfdir}/ssmtp
30         install -m 0644 ${WORKDIR}/ssmtp.conf ${D}${sysconfdir}/ssmtp/ssmtp.conf
31 }
32
33 pkg_postinst () {
34         update-alternatives --install ${sbindir}/sendmail sendmail ${bindir}/ssmtp 30
35 }
36
37 pkg_postrm () {
38         update-alternatives --remove ${sbindir}/sendmail sendmail
39 }