Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / speex / speex_1.2.bb
1 DESCRIPTION = "Speex is an Open Source/Free Software patent-free audio compression format designed for speech."
2 SECTION = "libs/multimedia"
3 LICENSE = "BSD"
4 HOMEPAGE = "http://www.speex.org"
5 DEPENDS = "libogg"
6 BETA = "1.2rc1"
7 PV = "1.1+${BETA}"
8 PR = "r0"
9
10 SRC_URI = "http://downloads.us.xiph.org/releases/speex/speex-${BETA}.tar.gz"
11 S = "${WORKDIR}/speex-${BETA}"
12
13 PARALLEL_MAKE = ""
14
15 inherit autotools pkgconfig
16
17 LEAD_SONAME = "libspeex.so"
18
19 # Some interesting options are:
20 #
21 #       --enable-arm4-asm
22 #       --enable-arm5e-asm
23 #       --enable-blackfin-asm
24 #       --enable-fixed-point
25 #       --disable-float-api --disable-vbr (must disable-vbr if disable-float-api)
26 #
27
28 EXTRA_OECONF_append_openmn = " --enable-arm5e-asm --enable-fixed-point --disable-float-api --disable-vbr "
29 EXTRA_OECONF_append_amsdelta = " --enable-arm4-asm --enable-fixed-point --disable-float-api --disable-vbr "
30 EXTRA_OECONF_append_bfin = " --enable-blackfin-asm --enable-fixed-point --disable-float-api --disable-vbr "
31 EXTRA_OECONF_append_arm = " --enable-fixed-point --disable-float-api --disable-vbr "
32 EXTRA_OECONF_append_dht-walnut = " --enable-fixed-point --disable-float-api --disable-vbr "
33
34
35
36 do_configure_append() {
37         sed -i s/"^OGG_CFLAGS.*$"/"OGG_CFLAGS = "/g Makefile */Makefile */*/Makefile
38         sed -i s/"^OGG_LIBS.*$"/"OGG_LIBS = -logg"/g Makefile */Makefile */*/Makefile
39         find . -name "Makefile" -exec sed -i s,-I/usr/include,, {} \;
40 }
41
42 do_stage() {
43         autotools_stage_all
44 }
45
46 PACKAGES =+ "${PN}-utils ${PN}-dsp"
47 FILES_${PN}-utils = "${bindir}/speex*"
48 FILES_${PN}-dsp = "${libdir}/libspeexdsp.so.*"
49 FILES_${PN} = "${libdir}/libspeex.so.*"