increase dvbapp PR
[vuplus_openembedded] / recipes / snes9x / snes9x_1.43-WIP1.bb
1 SECTION = "x11/games"
2 PR = "r4"
3 LICENSE = "snes9x"
4 DEPENDS = "libxxf86dga libxxf86vm"
5 DEPENDS_append_i686 = " nasm-native"
6 RDEPENDS_epia = "kernel-module-joydev"
7
8 SRC_URI = "http://www.lysator.liu.se/snes9x/1.43-WIP1/snes9x-1.43-WIP1-src.tar.gz \
9         file://makefile.patch;patch=1;pnum=2 \
10         file://private.patch;patch=1;pnum=0 \
11         file://64bit.patch;patch=1 \
12         file://configure.patch;patch=1;pnum=0 \
13         file://linkage.patch;patch=1;pnum=0"
14
15 S = "${WORKDIR}/snes9x-1.43-dev-src/snes9x"
16
17 inherit autotools
18
19 export OECFLAGS="${CFLAGS}"
20 export OELDFLAGS="${LDFLAGS}"
21
22 do_configure() {
23         oe_runconf
24 }
25
26 do_install() {
27         install -d ${D}${bindir}
28         install snes9x ${D}${bindir}
29 }