increase dvbapp PR.
[vuplus_openembedded] / recipes / snes9x / snes9x-sdl-qpe_1.39.bb
1 DESCRIPTION = "Super Nintendo Emulator based on SDL, QtE Palmtop Environments Edition"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 DEPENDS = "libsdl-qpe"
5 LICENSE = "snes9x"
6 PR = "r4"
7
8 SRC_URI = "http://www.vanille.de/mirror/snes9x-sdl-${PV}.tar.bz2 \
9            file://compile.patch;patch=1"
10 S = "${WORKDIR}/snes9x-sdl-${PV}"
11
12 FILESPATH = "${FILE_DIRNAME}/${PN}-${PV}:${FILE_DIRNAME}/snes9x-sdl-${PV}:${FILE_DIRNAME}/snes9x-sdl:${FILE_DIRNAME}/files:${FILE_DIRNAME}"
13
14 inherit qmake_base
15
16 QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'
17
18 do_compile() {
19         oe_runmake CC="${CC}" CCC="${CXX}" \
20                    INCLUDES="-I${STAGING_INCDIR} `sdl-config --cflags`" \
21                    LDLIBS="`sdl-config --libs` -L${OE_QMAKE_LIBDIR_QT} -Wl,-rpath-link,${STAGING_LIBDIR} -lqpe -l${QT_LIBRARY}"
22 }
23
24 do_install() {
25         install -d ${D}${palmtopdir}/bin/
26         install -m 0755 snes9x ${D}${palmtopdir}/bin/snes9x
27 }
28
29 FILES_${PN} = "${palmtopdir}/bin/snes9x"