update driver
[vuplus_openembedded] / recipes / sidplayer / sidplayer_1.5.0.bb
1 DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
2 SECTION = "opie/multimedia"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 HOMEPAGE = "http://sidplayer.sourceforge.net/"
6 DEPENDS = "libsidplay"
7 PR = "r1"
8
9 SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
10            file://use-external-libsidplay.patch;patch=1 \
11            file://gcc3.patch;patch=1 \
12            file://gcc34.patch;patch=1"
13 S = "${WORKDIR}/sidplayer"
14
15 EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/sidplay"
16
17 inherit palmtop
18
19 do_install() {
20         install -d ${D}${palmtopdir}/bin \
21                    ${D}${palmtopdir}/apps/Applications \
22                    ${D}${palmtopdir}/pics
23         cp -pPR ../apps ../bin ../pics ${D}${palmtopdir}/
24 }