increase dvbapp PR.
[vuplus_openembedded] / recipes / shr / shr-settings_git.bb
1 DESCRIPTION = "Modular settings application for SHR based on python-elementary"
2 HOMEPAGE = "http://shr-project.org"
3 SHR_RELEASE ?= "shr"
4 LICENSE ?= "GPL"
5 RDEPENDS = "python-elementary python-dbus python-codecs python-shell python-pyrtc python python-core python-edbus dbus-x11 frameworkd python-phoneutils python-pexpect"
6 SECTION = "x11/application"
7 PE = "1"
8 PV = "0.1.1+gitr${SRCREV}"
9 PR = "r8"
10
11 inherit setuptools
12
13 PACKAGES =+ "\
14   ${PN}-addons-illume \
15   ${PN}-backup-configuration \
16 "
17
18 RRECOMMENDS_${PN} = "\
19   ${PN}-addons-illume \
20   ${PN}-backup-configuration \
21 "
22
23 PACKAGE_ARCH_${PN}-addons-illume = "all"
24 PACKAGE_ARCH_${PN}-backup-configuration = "all"
25
26 SRC_URI = "git://git.shr-project.org/repo/shr-settings.git;protocol=http;branch=master"
27 S = "${WORKDIR}/git"
28 FILES_${PN} += "${prefix}/share/pixmaps"
29 FILES_${PN} += "${prefix}/share/applications"
30 FILES_${PN}-addons-illume = "${prefix}/share/applications/shr-settings-addons-illume"
31 FILES_${PN}-backup-configuration = "${sysconfdir}/shr-settings/"
32 CONFFILES_${PN}-backup-configuration = "${sysconfdir}/shr-settings/*"