increase dvbapp PR.
[vuplus_openembedded] / recipes / shr / shr-launcher_svn.bb
1 DESCRIPTION = "shr-launcher is a home app/launcher for openmoko phones"
2 HOMEPAGE = "http://code.google.com/p/shr-launcher/"
3 AUTHOR = "cchandel"
4 LICENSE = "GPLv2"
5 SECTION = "e/apps"
6 DEPENDS = "elementary eina edbus"
7
8 PV = "0.0.1+svnr${SRCPV}"
9 PR = "r5"
10
11 SRC_URI = "svn://shr-launcher.googlecode.com/svn;module=trunk;proto=http"
12
13 S = "${WORKDIR}/trunk"
14
15 inherit autotools
16
17 do_install_append() {
18         install -d "${D}/${datadir}/pixmaps"
19         install -m 0644 "${S}/resources/launcher.png" "${D}/${datadir}/pixmaps"
20         install -d "${D}/${datadir}/applications"
21         install -m 0644 "${S}/resources/launcher.desktop" "${D}/${datadir}/applications"
22         install -d "${D}/${datadir}/launcher"
23         for ico in "${S}/resources/"*.png; do
24                 if [ "$(basename $ico)" != "launcher.png" ]; then
25                         install -m 0644 $ico "${D}/${datadir}/launcher"
26                 fi
27         done
28 }
29
30 FILES_${PN} += "/usr/share/launcher/* /usr/share/applications/* /usr/share/pixmaps/*"