Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / shopper / shopper_1.2.1.bb
1 DESCRIPTION = "Shopping list manager"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5
6 PR = "r1"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/zaurus-shopper/Shopper-${PV}.tar.gz \
9            file://gcc3.patch;patch=1 \
10            file://path_fix.patch;patch=1"
11 S = "${WORKDIR}/Shopper"
12
13 inherit palmtop
14
15 SHOPPER_DATADIR = "${palmtopdir}/share/shopper"
16 CXXFLAGS_append += " -DSHOPPER_DATADIR='"${SHOPPER_DATADIR}"' "
17
18 QMAKE_PROFILES = "Shopper.pro"
19
20 pkg_postinst() {
21         /opt/QtPalmtop/bin/qcop QPE/System "linkChanged(QString)" 2>/dev/null
22         if [ -n "$D" ]; then false; fi
23 }
24
25 do_install() {
26         install -d ${D}${palmtopdir}/bin \
27                    ${D}${palmtopdir}/apps/Applications \
28                    ${D}${palmtopdir}/pics \
29                    ${D}${palmtopdir}/help/html \
30                ${D}${SHOPPER_DATADIR}
31         install -m 0755 ${S}/Shopper ${D}${palmtopdir}/bin/
32         install -m 0644 ${S}/Shopper.desktop ${D}${palmtopdir}/apps/Applications/
33         install -m 0644 ${S}/Shopper.png ${D}${palmtopdir}/pics/
34         install -m 0644 ${S}/Shopper.html ${D}${palmtopdir}/help/html/
35         install -m 0644 ${S}/shoppinglist.xml ${D}${SHOPPER_DATADIR}/shoppinglist.xml
36 }