increase dvbapp PR
[vuplus_openembedded] / recipes / sharp-binary-only / sharp-camera-support_2.4.18-rmk7-pxa3-embedix.bb
1 DESCRIPTION = "Driver for the SHARP CG-AG06 digital compact flash camera for linux ${PV}"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 LICENSE = "CLOSED"
5 RDEPENDS = "kernel (${KERNEL_VERSION})"
6 PR = "r4"
7
8 SRC_URI = "http://openzaurus.sf.net/mirror/camera-modules-2.4.18-rmk7-pxa3-embedix.tar.bz2 \
9            file://CE-AG06.dat \
10            file://sharpzdc \
11            file://sharpzdc.conf"
12 S = "${WORKDIR}"
13
14 COMPATIBLE_MACHINE = '(collie|poodle|tosa)'
15
16 inherit module-base
17
18 do_install() {
19         install -d ${D}${sysconfdir}/pcmcia/cis
20         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia
21         install -m 0644 ${WORKDIR}/CE-AG06.dat ${D}${sysconfdir}/pcmcia/cis/
22         install -m 0644 ${WORKDIR}/sharpzdc.conf ${D}${sysconfdir}/pcmcia/
23         install -m 0755 ${WORKDIR}/sharpzdc ${D}${sysconfdir}/pcmcia/
24         install -m 0644 ${MACHINE}/sharpzdc_cs.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
25 }
26
27 FILES_${PN} = "/"
28
29 PACKAGE_ARCH = "${MACHINE_ARCH}"