increase dvbapp PR.
[vuplus_openembedded] / recipes / sgml-common / sgml-common_0.6.3.bb
1 LICENSE = "GPL"
2 SECTION = "base"
3 DESCRIPTION = "The sgml-common package gathers very basic \
4 stuff necessary to work with SGML and XML, such as xml.dcl, \
5 a SGML declaration of XML; iso-entities, a list of the basic \
6 SGML ISO entities; and install-catalog, a script used to \
7 add entries to (or remove entries from) centralized catalogs \
8 whose entries are pointers to SGML open catalogs, \
9 as defined by OASIS."
10
11 FILES_sgml-common_append = " ${datadir}/sgml"
12
13 SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-common-${PV}.tgz \
14            file://autohell.patch;patch=1"
15
16 inherit autotools
17
18 do_compile_append() {
19     # install-catalog script contains hardcoded reference to /etc/sgml.
20     sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/install-catalog
21 }
22
23 pkg_postinst() {
24         install-catalog \
25             --add ${sysconfdir}/sgml/sgml-ent.cat \
26                         ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
27             
28         install-catalog \
29             --add ${sysconfdir}/sgml/sgml-docbook.cat \
30                         ${sysconfdir}/sgml/sgml-ent.cat
31 }
32
33 pkg_postrm() {
34         install-catalog \
35             --remove ${sysconfdir}/sgml/sgml-ent.cat \
36                         ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
37             
38         install-catalog \
39             --remove ${sysconfdir}/sgml/sgml-docbook.cat \
40                         ${sysconfdir}/sgml/sgml-ent.cat
41 }
42