rename packages/ to recipes/ per earlier agreement
[vuplus_openembedded] / recipes / sdlperl / sdl-perl_1.20.3.bb
1 DESCRIPTION = "Perl bindings for SDL"
2 SECTION = "libs"
3 HOMEPAGE = "http://sdl.perl.org/"
4 LICENSE = "GPL"
5 DEPENDS = "perl virtual/libsdl libsdl-image libsdl-gfx libsdl-ttf libsdl-mixer libsdl-net smpeg"
6 PR = "r1"
7
8 SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz"
9 S = "${WORKDIR}/SDL_perl-${PV}"
10
11 inherit cpan
12
13 do_configure_prepend() {
14         # Search staging area for includes
15         sed -i -e 's:/usr/\(local/\)\{0,1\}include:${STAGING_INCDIR}:g' Makefile.linux
16         # smpeg.h isn't in a subdirectry
17         sed -i -e 's:#include <smpeg/smpeg.h>:#include <smpeg.h>:g' SDL_perl.xs
18 }