Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / sane / sane-backends_1.0.20.bb
1 DESCRIPTION = "Scanner drivers for SANE"
2 DEPENDS = "hal gphoto2 jpeg virtual/libusb0"
3 LICENSE = "LGPL"
4
5 SRC_URI = "http://alioth.debian.org/frs/download.php/3026/sane-backends-${PV}.tar.gz \
6         file://Makefile.in.patch;patch=1 \
7         file://saned.xinetd \
8         file://byteorder.m4 \
9         file://stdint.m4 \
10         "
11
12 inherit autotools pkgconfig binconfig
13
14 EXTRA_OECONF = "--disable-translations"
15
16 do_configure_prepend() {
17         mkdir -p ${S}/m4
18         cp ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/m4/
19         cp ${WORKDIR}/*.m4 ${S}/m4/
20 }
21
22 PARALLEL_MAKE = ""
23 do_compile_prepend() {
24         ln -sf ${S}/${TARGET_PREFIX}libtool ${S}/libtool
25 }       
26
27 do_install_append() {
28         install -d "${D}/${sysconfdir}/xinetd.d"
29         install -m 755 "${S}/tools/.libs/sane-find-scanner" "${D}/${bindir}"
30         install -m 644 "${WORKDIR}/saned.xinetd" "${D}/${sysconfdir}/xinetd.d/saned"
31 }
32
33 PACKAGES =+ "libsane libsane-dev saned sane-utils"
34
35 FILES_libsane = "${libdir}/sane/*.so.* ${libdir}/lib*.so.* /etc"
36 RRECOMMENDS_libsane = "saned sane-utils"
37 FILES_libsane-dev += "${libdir}/sane/*"
38
39 RRECOMMENDS_saned = "xinetd"
40 FILES_saned = "${sbindir}/saned"
41
42 FILES_sane-utils = "${bindir}/*"
43 FILES_${PN}-dbg += "${libdir}/sane/.debug"
44
45
46 CONFFILES_libsane = "${sysconfdir}/sane.d/abaton.conf ${sysconfdir}/sane.d/agfafocus.conf ${sysconfdir}/sane.d/apple.conf ${sysconfdir}/sane.d/artec.conf ${sysconfdir}/sane.d/avision.conf ${sysconfdir}/sane.d/bh.conf ${sysconfdir}/sane.d/canon.conf ${sysconfdir}/sane.d/canon630u.conf ${sysconfdir}/sane.d/coolscan.conf ${sysconfdir}/sane.d/coolscan2.conf ${sysconfdir}/sane.d/dc25.conf ${sysconfdir}/sane.d/dmc.conf ${sysconfdir}/sane.d/epson.conf ${sysconfdir}/sane.d/fujitsu.conf ${sysconfdir}/sane.d/gt68xx.conf ${sysconfdir}/sane.d/hp.conf  ${sysconfdir}/sane.d/leo.conf ${sysconfdir}/sane.d/matsushita.conf ${sysconfdir}/sane.d/microtek.conf ${sysconfdir}/sane.d/microtek2.conf ${sysconfdir}/sane.d/mustek.conf ${sysconfdir}/sane.d/mustek_usb.conf ${sysconfdir}/sane.d/nec.conf ${sysconfdir}/sane.d/pie.conf ${sysconfdir}/sane.d/plustek.conf ${sysconfdir}/sane.d/plustek_pp.conf ${sysconfdir}/sane.d/ricoh.conf ${sysconfdir}/sane.d/s9036.conf ${sysconfdir}/sane.d/sceptre.conf ${sysconfdir}/sane.d/sharp.conf ${sysconfdir}/sane.d/sp15c.conf ${sysconfdir}/sane.d/st400.conf ${sysconfdir}/sane.d/tamarack.conf ${sysconfdir}/sane.d/test.conf ${sysconfdir}/sane.d/teco1.conf ${sysconfdir}/sane.d/teco2.conf ${sysconfdir}/sane.d/teco3.conf ${sysconfdir}/sane.d/umax.conf ${sysconfdir}/sane.d/umax_pp.conf ${sysconfdir}/sane.d/umax1220u.conf ${sysconfdir}/sane.d/artec_eplus48u.conf ${sysconfdir}/sane.d/ma1509.conf ${sysconfdir}/sane.d/ibm.conf ${sysconfdir}/sane.d/hp5400.conf ${sysconfdir}/sane.d/u12.conf ${sysconfdir}/sane.d/snapscan.conf ${sysconfdir}/sane.d/dc210.conf ${sysconfdir}/sane.d/dc240.conf ${sysconfdir}/sane.d/gphoto2.conf ${sysconfdir}/sane.d/net.conf ${sysconfdir}/sane.d/dll.conf ${sysconfdir}/sane.d/saned.conf"
47
48 do_stage() {
49         autotools_stage_all    
50 }
51
52
53