increase dvbapp PR.
[vuplus_openembedded] / recipes / sane / sane-backends_1.0.19.bb
1 DESCRIPTION = "Scanner drivers for SANE"
2 DEPENDS = "hal gphoto2 jpeg virtual/libusb0"
3 LICENSE = "LGPL"
4
5 SRC_URI = "http://alioth.debian.org/frs/download.php/2318/sane-backends-${PV}.tar.gz \
6         file://Makefile.in.patch;patch=1 \
7         file://saned.xinetd \
8         file://byteorder.m4 \
9         file://stdint.m4 \
10         file://sane-symbols.diff;patch=1 \
11         "
12
13 inherit autotools pkgconfig binconfig
14
15 EXTRA_OECONF = "--disable-translations"
16
17 do_configure_prepend() {
18         mkdir -p ${S}/m4
19         cp ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/m4/
20         cp ${WORKDIR}/*.m4 ${S}/m4/
21 }
22
23 PARALLEL_MAKE = ""
24 do_compile_prepend() {
25         ln -sf ${S}/${TARGET_PREFIX}libtool ${S}/libtool
26 }       
27
28 do_install_append() {
29         install -d "${D}/${sysconfdir}/xinetd.d"
30         install -m 755 "${S}/tools/.libs/sane-find-scanner" "${D}/${bindir}"
31         install -m 644 "${WORKDIR}/saned.xinetd" "${D}/${sysconfdir}/xinetd.d/saned"
32 }
33
34 PACKAGES =+ "libsane libsane-dev saned sane-utils"
35
36 FILES_libsane = "${libdir}/sane/*.so.* ${libdir}/lib*.so.* /etc"
37 RRECOMMENDS_libsane = "saned sane-utils"
38 FILES_libsane-dev += "${libdir}/sane/*"
39
40 RRECOMMENDS_saned = "xinetd"
41 FILES_saned = "${sbindir}/saned"
42
43 FILES_sane-utils = "${bindir}/*"
44 FILES_${PN}-dbg += "${libdir}/sane/.debug"
45
46
47 CONFFILES_libsane = "${sysconfdir}/sane.d/abaton.conf ${sysconfdir}/sane.d/agfafocus.conf ${sysconfdir}/sane.d/apple.conf ${sysconfdir}/sane.d/artec.conf ${sysconfdir}/sane.d/avision.conf ${sysconfdir}/sane.d/bh.conf ${sysconfdir}/sane.d/canon.conf ${sysconfdir}/sane.d/canon630u.conf ${sysconfdir}/sane.d/coolscan.conf ${sysconfdir}/sane.d/coolscan2.conf ${sysconfdir}/sane.d/dc25.conf ${sysconfdir}/sane.d/dmc.conf ${sysconfdir}/sane.d/epson.conf ${sysconfdir}/sane.d/fujitsu.conf ${sysconfdir}/sane.d/gt68xx.conf ${sysconfdir}/sane.d/hp.conf  ${sysconfdir}/sane.d/leo.conf ${sysconfdir}/sane.d/matsushita.conf ${sysconfdir}/sane.d/microtek.conf ${sysconfdir}/sane.d/microtek2.conf ${sysconfdir}/sane.d/mustek.conf ${sysconfdir}/sane.d/mustek_usb.conf ${sysconfdir}/sane.d/nec.conf ${sysconfdir}/sane.d/pie.conf ${sysconfdir}/sane.d/plustek.conf ${sysconfdir}/sane.d/plustek_pp.conf ${sysconfdir}/sane.d/ricoh.conf ${sysconfdir}/sane.d/s9036.conf ${sysconfdir}/sane.d/sceptre.conf ${sysconfdir}/sane.d/sharp.conf ${sysconfdir}/sane.d/sp15c.conf ${sysconfdir}/sane.d/st400.conf ${sysconfdir}/sane.d/tamarack.conf ${sysconfdir}/sane.d/test.conf ${sysconfdir}/sane.d/teco1.conf ${sysconfdir}/sane.d/teco2.conf ${sysconfdir}/sane.d/teco3.conf ${sysconfdir}/sane.d/umax.conf ${sysconfdir}/sane.d/umax_pp.conf ${sysconfdir}/sane.d/umax1220u.conf ${sysconfdir}/sane.d/artec_eplus48u.conf ${sysconfdir}/sane.d/ma1509.conf ${sysconfdir}/sane.d/ibm.conf ${sysconfdir}/sane.d/hp5400.conf ${sysconfdir}/sane.d/u12.conf ${sysconfdir}/sane.d/snapscan.conf ${sysconfdir}/sane.d/dc210.conf ${sysconfdir}/sane.d/dc240.conf ${sysconfdir}/sane.d/gphoto2.conf ${sysconfdir}/sane.d/v4l.conf ${sysconfdir}/sane.d/net.conf ${sysconfdir}/sane.d/dll.conf ${sysconfdir}/sane.d/saned.conf"
48
49 do_stage() {
50         autotools_stage_all    
51 }
52
53
54