Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / samba / samba_3.3.9.bb
1 require samba.inc
2 require samba-basic.inc
3 LICENSE = "GPLv3"
4
5 # 3.3.0 and newer will upgrade your tdb database to a
6 # new version that you can not downgrade to use with older
7 # releases. More testing will happen before this is removed
8 # should there be further issues. Appears to work though :)
9 DEFAULT_PREFERENCE = "-1"
10
11 SRC_URI += "file://configure-3.3.0.patch;patch=1 \
12             file://config-h.patch;patch=1 \
13             file://mtab.patch;patch=1 \
14             file://tdbheaderfix.patch;patch=1 "
15
16 PR = "r4"
17
18 EXTRA_OECONF += "\
19         SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
20         samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
21         linux_getgrouplist_ok=no \
22         samba_cv_HAVE_BROKEN_GETGROUPS=no \
23         samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
24         samba_cv_have_setresuid=yes \
25         samba_cv_have_setresgid=yes \
26         samba_cv_HAVE_WRFILE_KEYTAB=yes \
27         "
28
29 do_configure() {
30         oe_runconf
31 }
32
33 do_compile () {
34         base_do_compile
35 }