Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / samba / samba_3.3.0.bb
1 require samba.inc
2 require samba-basic.inc
3
4 # 3.3.0 and newer will upgrade your tdb database to a
5 # new version that you can not downgrade to use with older
6 # releases. More testing will happen before this is removed
7 # should there be further issues. Appears to work though :)
8 DEFAULT_PREFERENCE = "-1"
9
10 SRC_URI += "file://configure-3.3.0.patch;patch=1 \
11             file://config-h.patch;patch=1 \
12             file://mtab.patch;patch=1 \
13                 "
14
15 PR = "r2"
16
17 EXTRA_OECONF += "\
18         SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
19         samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
20         linux_getgrouplist_ok=no \
21         samba_cv_HAVE_BROKEN_GETGROUPS=no \
22         samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
23         samba_cv_have_setresuid=yes \
24         samba_cv_have_setresgid=yes \
25         samba_cv_HAVE_WRFILE_KEYTAB=yes \
26         "
27
28 do_configure() {
29         oe_runconf
30 }
31
32 do_compile () {
33         base_do_compile
34 }