increase dvbapp PR.
[vuplus_openembedded] / recipes / samba / samba_3.0.33.bb
1 require samba.inc
2 inherit update-rc.d
3
4 PR = "r8"
5
6 SRC_URI += "file://config-lfs.patch;patch=1 \
7             file://quota.patch;patch=1;pnum=0 \
8             file://init \
9             file://smb.conf \
10                 "
11
12 #          file://cifs.patch;patch=1 \
13
14 INITSCRIPT_NAME = "samba"
15 # No dependencies, goes in at level 20 (NOTE: take care with the
16 # level, later levels put the shutdown later too - see the links
17 # in rc6.d, the shutdown must precede network shutdown).
18 INITSCRIPT_PARAMS = "defaults"
19 CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
20 CONFFILES_${PN}_opendreambox = ""
21
22 # The file system settings --foodir=dirfoo and overridden unconditionally
23 # in the samba config by --with-foodir=dirfoo - even if the --with is not
24 # specified!  Fix that here.  Set the privatedir to /etc/samba/private.
25 EXTRA_OECONF += "\
26         SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
27         samba_cv_struct_timespec=yes \
28         --with-configdir=${sysconfdir}/samba \
29         --with-privatedir=${sysconfdir}/samba/private \
30         --with-lockdir=${localstatedir}/lock \
31         --with-piddir=${localstatedir}/run \
32         --with-logfilebase=${localstatedir}/log \
33         --with-libdir=${libdir} \
34         --with-mandir=${mandir} \
35         --with-swatdir=${datadir}/swat \
36         "
37
38 do_install_append() {
39         install -d "${D}/var/log/samba"
40         install -d "${D}${sysconfdir}/init.d"
41         install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
42         install -d "${D}${sysconfdir}/samba"
43         install -c -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
44         install -d ${D}/var/spool/samba
45 }
46
47 PACKAGES =+ "swat"
48
49 FILES_swat       = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
50 FILES_${PN}     += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat \
51                     ${libdir}/auth/*.so ${libdir}/security/*.so"
52 FILES_${PN}-dbg += "${libdir}/vfs/.debug/*.so ${libdir}/charset/.debug/*.so \
53                     ${libdir}/auth/.debug/*.so ${libdir}/security/.debug/*.so"
54
55 #
56 # bug fix for samba.inc:
57 FILES_cifs-doc += "${mandir}/man8/mount.cifs.8"