modify recipes/samba
[vuplus_openembedded] / recipes / samba / samba_3.0.23c.bb
1 require samba.inc
2 require samba-basic.inc
3
4 SRC_URI += "file://configure.patch;patch=1 \
5             file://cifs.patch;patch=1"
6
7 PR = "r7"
8
9 SRC_URI_append_opendreambox = "file://smb.conf"
10
11 PACKAGES =+ " smbfs-doc"
12
13 EXTRA_OECONF += "\
14         --with-smbmount \
15         "
16
17 PACKAGES =+ " smbfs smbfs-doc"
18 RCONFLICTS_smbfs-doc = "smbfs-ads-doc"
19 FILES_smbfs = "${bindir}/smbmount ${bindir}/smbumount ${bindir}/smbmnt ${base_sbindir}/mount.smbfs ${base_sbindir}/mount.smb"
20 FILES_smbfs-doc = "${mandir}/man8/smbmount.8 ${mandir}/man8/smbumount.8 ${mandir}/man8/smbmnt.8"
21
22 do_compile () {
23         oe_runmake proto_exists
24         base_do_compile
25         ${CC} client/mount.cifs.c -o mount.cifs
26 }
27
28 do_stage() {
29         install -m 0644 include/libsmbclient.h ${STAGING_INCDIR}
30         oe_libinstall -C bin -a -so libsmbclient ${STAGING_LIBDIR}
31 }