increase dvbapp PR.
[vuplus_openembedded] / recipes / sablevm / sablevm_1.11.3.bb
1 DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
2 HOMEPAGE = "http://sablevm.org"
3 LICENSE = "LGPL"
4 PRIORITY = "optional"
5 SECTION = "interpreters"
6
7 DEPENDS = "libffi libtool popt \
8            sablevm-classpath"
9 #          unzip"
10 RRECOMMENDS = "sablevm-classpath (>= ${PV})"
11
12 SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
13
14 inherit autotools update-alternatives
15
16 EXTRA_OECONF = "--enable-real-life-brokenness \
17                 --disable-errors-on-warnings --disable-signals-for-exceptions"
18
19 PROVIDES = "virtual/java"
20 ALTERNATIVE_NAME = "java"
21 ALTERNATIVE_PATH = "${bindir}/java-sablevm"
22 ALTERNATIVE_PRIORITY = "350"
23
24 PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
25
26 FILES_${PN} = "${bindir} \
27                ${libdir}/${PN}/bin"
28
29 FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
30
31 FILES_lib${PN}-dev = "${includedir}/jni* \
32                       ${libdir}/lib${PN}.so \
33                       ${libdir}/lib${PN}.la"
34
35 do_install_append() {
36         install -d ${D}${docdir}
37         mv ${D}${datadir}/${PN} ${D}${docdir}/
38
39         # symlink only present in the deb...
40         install -d ${D}${libdir}/${PN}/bin
41         cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
42 }