increase dvbapp PR.
[vuplus_openembedded] / recipes / rxvt-unicode / rxvt-unicode_cvs.bb
1 SECTION = "x11/utils"
2 DEPENDS = "virtual/libx11 libxt libxft"
3 DESCRIPTION = "rxvt-unicode is a clone of the well known \
4 terminal emulator rxvt, modified to store text in Unicode \
5 (either UCS-2 or UCS-4) and to use locale-correct input and \
6 output. It also supports mixing multiple fonts at the \
7 same time, including Xft fonts."
8 DEFAULT_PREFERENCE = "-1"
9 LICENSE = "GPL"
10 SRC_URI = "cvs://anonymous@cvs.schmorp.de/schmorpforge;module=rxvt-unicode;port=636 \
11            file://xwc.patch;patch=1 \
12            file://signedchar.patch;patch=1 \
13            file://makefile.patch;patch=1"
14
15 inherit autotools update-alternatives
16
17 PROVIDES = "virtual/x-terminal-emulator"
18 ALTERNATIVE_NAME = "x-terminal-emulator"
19 ALTERNATIVE_PATH = "${bindir}/rxvt"
20
21 S = "${WORKDIR}/rxvt-unicode"
22
23 CFLAGS_append = " -fpermissive"
24
25 EXTRA_OECONF = "--enable-menubar --enable-xim \
26                 --enable-utmp --enable-wtmp --enable-lastlog \
27                 --disable-strings --with-term=rxvt --enable-keepscrolling \
28                 --enable-xft --with-name=rxvt --enable-frills \
29                 --enable-swapscreen --enable-transparency \
30                 --with-codesets=eu,jp \
31                 --enable-cursor-blink --enable-pointer-blank \
32                 --enable-text-blink --enable-plain-scroll \
33                 --enable-combining --enable-shared \
34                 --enable-xgetdefault \
35                 --with-x=${STAGING_LIBDIR}/.."
36 EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
37                 'XLIB=-L${STAGING_LIBDIR} -lX11'"
38
39 do_configure () {
40         mv autoconf/configure.in . || true
41         rm autoconf/libtool.m4
42         libtoolize --force
43         autotools_do_configure
44         echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
45         echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
46         echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
47         echo '#define HAVE_XLOCALE 1' >> config.h
48 }
49
50 do_compile () {
51         if test -e ${S}/${HOST_SYS}-libtool; then
52                 LIBTOOL=${S}/${HOST_SYS}-libtool
53         else
54                 LIBTOOL=${S}/libtool
55         fi
56         # docs need "yodl" and I have no idea what that is
57         oe_runmake -C src "LIBTOOL=$LIBTOOL"
58 }