add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / rxvt-unicode / rxvt-unicode_7.7.bb
1 SECTION = "x11/utils"
2 DEPENDS = "virtual/libx11 libxt libxft libxpm"
3 DESCRIPTION = "rxvt-unicode is a clone of the well known \
4 terminal emulator rxvt, modified to store text in Unicode \
5 (either UCS-2 or UCS-4) and to use locale-correct input and \
6 output. It also supports mixing multiple fonts at the \
7 same time, including Xft fonts."
8 LICENSE = "GPL"
9 PACKAGES =+ "${PN}-daemon ${PN}-control"
10 FILES_${PN}-daemon = "${bindir}/rxvtd"
11 FILES_${PN}-control = "${bindir}/rxvtc"
12
13 SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
14            file://xwc.patch;patch=1 \
15            file://signedchar.patch;patch=1"
16 PR = "r0"
17
18 DEFAULT_PREFERENCE = "-1"
19
20 inherit autotools update-alternatives
21
22 PROVIDES = "virtual/x-terminal-emulator"
23 ALTERNATIVE_NAME = "x-terminal-emulator"
24 ALTERNATIVE_PATH = "${bindir}/rxvt"
25
26 CFLAGS_append = " -fpermissive"
27
28 EXTRA_OECONF = "--enable-menubar --enable-xim \
29                 --enable-utmp --enable-wtmp --enable-lastlog \
30                 --disable-strings --with-term=rxvt --enable-keepscrolling \
31                 --enable-xft --with-name=rxvt --enable-frills \
32                 --enable-swapscreen --enable-transparency \
33                 --with-codesets=eu \
34                 --enable-cursor-blink --enable-pointer-blank \
35                 --enable-text-blink --enable-rxvt-scroll \
36                 --enable-combining --enable-shared \
37                 --enable-xgetdefault \
38                 --with-x=${STAGING_LIBDIR}/.. \
39                 --enable-xpm-background \
40                 --disable-perl \
41                 --with-xpm-includes=${STAGING_INCDIR} \
42                 --with-xpm-libs=${STAGING_LIBDIR}"
43
44 do_configure_prepend () {
45         cp aclocal.m4 acinclude.m4
46 }
47
48 do_compile_prepend () {
49         echo '#define UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
50         echo '#define WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
51         echo '#define LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
52         echo '#define HAVE_XLOCALE 1' >> config.h
53 }
54