Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / robostix-module / robostix-module.bb
1 DESCRIPTION = "Linux Driver for Gumstix robostix daughtercards"
2 SECTION = "base"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 RDEPENDS = "kernel (${KERNEL_VERSION})"
6 DEPENDS = "virtual/kernel"
7
8 PR = "r1"
9
10 INITSCRIPT_NAME = "robostix"
11 INITSCRIPT_PARAMS = "defaults 10"
12
13 SRC_URI = "\
14   file://Makefile \
15   file://robostix.h \
16   file://robostix.c \
17   file://robostix.init \
18  "
19
20 S = "${WORKDIR}"
21
22 inherit module update-rc.d
23
24 do_install() {  
25         install         -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
26   install -m 0644 ${WORKDIR}/robostix.ko ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
27
28         install         -d ${D}${sysconfdir}/init.d/
29         install -m 0755 ${WORKDIR}/robostix.init ${D}${sysconfdir}/init.d/robostix
30 }
31
32 PACKAGES = "${PN}"
33
34 FILES_${PN} = "${base_libdir}/modules/"
35 FILES_${PN} += "${sysconfdir}/"
36