merge with org.openembedded.dev
[vuplus_openembedded] / recipes / resolvconf / resolvconf_1.43.bb
1 DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \
2 information about currently available nameservers. It sets \
3 itself up as the intermediary between programs that supply \
4 nameserver information and programs that need nameserver \
5 information."
6 SECTION = "console/network"
7 LICENSE = "GPL"
8 AUTHOR = "Thomas Hood"
9 HOMEPAGE = "http://packages.debian.org/resolvconf"
10 DEPENDS = "bash"
11 RDEPENDS = "bash"
12
13 SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
14
15 do_compile () {
16         :
17 }
18
19 do_install () {
20         install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${base_sbindir} ${D}${localstatedir}/run/resolvconf/interface
21         install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
22         cp -pPR etc/* ${D}${sysconfdir}/
23         install -m 0755 bin/resolvconf ${D}${base_sbindir}/
24         install -m 0644 README ${D}${docdir}/${P}/
25         install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
26 }
27
28 PACKAGE_ARCH = "all"
29