increase dvbapp PR.
[vuplus_openembedded] / recipes / readline / readline_5.2.bb
1 DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2 command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes  \
3 additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those   \
4 lines, and perform csh-like history expansion on previous commands."
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "GPLv2"
8 DEPENDS += "ncurses"
9 RPROVIDES_${PN} += "readline"
10 LEAD_SONAME = "libreadline.so"
11 PR = "r4"
12
13 SRC_URI = "ftp://ftp.gnu.org/gnu/readline/readline-${PV}.tar.gz \
14            file://configure_fix.patch;patch=1 \
15            file://acinclude.m4"
16
17 S = "${WORKDIR}/readline-${PV}"
18
19 inherit autotools
20
21 do_configure () {
22         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
23         autotools_do_configure
24 }
25
26 do_stage() {
27         autotools_stage_all
28 }
29
30 do_install () {
31         autotools_do_install
32         # Make install doesn't properly install these
33         oe_libinstall -so -C shlib libhistory ${D}${libdir}
34         oe_libinstall -so -C shlib libreadline ${D}${libdir}
35 }