increase dvbapp PR.
[vuplus_openembedded] / recipes / readline / readline_4.3.bb
1 DESCRIPTION = "The GNU Readline library provides a set of functions for use by applications that allow users to edit \
2 command lines as they are typed in. Both Emacs and vi editing modes are available. The Readline library includes  \
3 additional functions to maintain a list of previously-entered command lines, to recall and perhaps reedit those   \
4 lines, and perform csh-like history expansion on previous commands."
5 SECTION = "libs"
6 PRIORITY = "optional"
7 LICENSE = "GPLv2"
8 DEPENDS += "ncurses"
9 RPROVIDES_${PN} += "readline"
10 LEAD_SONAME = "libreadline.so"
11 PR = "r3"
12
13 SRC_URI = "${GNU_MIRROR}/readline/readline-${PV}.tar.gz \
14            file://shlink-termcap.patch;patch=1 \
15            file://acinclude.m4"
16 S = "${WORKDIR}/readline-${PV}"
17
18 inherit autotools
19
20 do_configure () {
21         install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
22         autotools_do_configure
23 }
24
25 do_stage() {
26         autotools_stage_all
27 }
28
29 do_install () {
30         autotools_do_install
31         # Make install doesn't properly install these
32         oe_libinstall -so -C shlib libhistory ${D}${libdir}
33         oe_libinstall -so -C shlib libreadline ${D}${libdir}
34 }