increase dvbapp PR.
[vuplus_openembedded] / recipes / qpf-fonts / qpf-qte_3.3.5.bb
1 require qpf.inc
2
3 DESCRIPTION = "Qt/Embedded fonts version ${PV}"
4 HOMEPAGE = "http://www.trolltech.com"
5 LICENSE = "GPL QPL"
6 PR = "r6"
7
8 SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
9 S = "${WORKDIR}/qt-embedded-free-${PV}"
10
11 do_compile() {
12         :
13 }
14
15 do_install() {
16         mkdir -p ${D}${sbindir}
17         mkdir -p ${D}${palmtopdir}/lib/fonts
18         cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
19         # Delete all other font formats, Qt/E would have a dead slow
20         # application start time if it had to use any other font format
21         # as *.qpf ...
22         find ${D}${palmtopdir}/lib/fonts \
23              -name "*.bdf" \
24           -o -name "*.ttf" \
25           -o -name "*.pfa" \
26           -o -name "*.pfb" | xargs rm
27 }
28
29 PACKAGES = "qte-font-fixed"
30 PROVIDES += "qte-font-fixed"
31 FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
32
33 PACKAGES += "qte-font-helvetica-small"
34 PROVIDES += "qte-font-helvetica-small"
35 FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
36         ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
37
38 PACKAGES += "qte-font-helvetica-large"
39 PROVIDES += "qte-font-helvetica-large"
40 FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
41         ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
42
43 PACKAGES += "qte-font-smoothtimes"
44 PROVIDES += "qte-font-smoothtimes"
45 FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
46
47 PACKAGES += "qte-font-smallsmooth"
48 PROVIDES += "qte-font-smallsmooth"
49 FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
50
51 PACKAGES += "qte-font-unicode"
52 PROVIDES += "qte-font-unicode"
53 FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
54
55 PACKAGES += "qte-font-micro"
56 PROVIDES += "qte-font-micro"
57 FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"