Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / qpe-games / fish_1.1.0.bb
1 DESCRIPTION = "Fish Amusement"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Robert Ernst"
6 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Fish.html"
7
8
9
10 SRC_URI = "http://handhelds.org/~zecke/oe_packages/fish_V1.1.0.tar.gz \
11            file://Makefile.patch;patch=1 \
12            file://fish.patch;patch=1"
13
14 PV = "1.1.0"
15 S = "${WORKDIR}/fish_V${PV}"
16
17 APPNAME = "fish"
18 APPTYPE = "binary"
19 APPDESKTOP = "${S}"
20
21
22 do_compile_prepend() {
23         oe_runmake -C images
24 }
25
26 do_install () {
27         install -d ${D}${palmtopdir}/pics/${APPNAME}/
28         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
29
30 }
31
32 inherit opie