Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / qpe-games / crossword_0.0.3.bb
1 DESCRIPTION = "Checkers"
2 SECTION = "opie/games"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 AUTHOR = "Robert Ernst"
6 HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Crossword.html"
7
8 SRC_URI = "http://handhelds.org/~zecke/oe_packages/crossword_V0.0.3.tar.gz \
9            file://crossword.patch;patch=1"
10
11 PR = "r1"
12
13 PV = "0.0.3"
14 S = "${WORKDIR}/crossword_V${PV}"
15
16 APPNAME = "crossword"
17 APPTYPE = "binary"
18 APPDESKTOP = "${S}"
19
20 do_install () {
21         install -d ${D}${palmtopdir}/pics/${APPNAME}/
22         install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
23
24 }
25
26 pkg_postinst() {
27 #!/bin/sh
28
29 MIMEFILE=/opt/QtPalmtop/etc/mime.types
30
31 grep -q application/puz $MIMEFILE 2>/dev/null || printf "application/crossword\t\tpuz tpz\n" >> $MIMEFILE
32 }
33
34 inherit opie