increase dvbapp PR.
[vuplus_openembedded] / recipes / qpe-gaim / qpe-libgaim_1.5.0.bb
1 DESCRIPTION = "A multi protocol instant messager library, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 DEPENDS = "glib-2.0 gnutls"
4 RDEPENDS = "libgaim-plugins"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://gaim.sourceforge.net/"
7 PR = "r3"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/gaim/gaim-${PV}.tar.bz2 \
10            file://dont-look-for-gtk.patch;patch=1        \
11            file://libgaim.patch;patch=1 "
12
13 S = "${WORKDIR}/gaim-${PV}"
14
15 inherit autotools
16
17 EXTRA_OE_CONF = "--disable-audio --disable-gtkspell --disable-perl \
18                  --disable-screensaver --disable-sm --disable-glibtest \
19                  --disable-gtktest --disable-startup-notification \
20                  --disable-gevolution --disable-aotest --disable-audiofiletest \
21                  --disable-x --without-x --without-gtk --disable-gtk \
22                  --enable-gnutls=y"
23
24 CFLAGS_append = " -I${STAGING_INCDIR}/glib-2.0"
25
26 do_stage() {
27         oe_libinstall -so -C src libgaim ${QTDIR}/lib
28
29         # install headers
30         GAIM_DIR=${STAGING_INCDIR}/gaim
31         install -d $GAIM_DIR
32
33         for header in account.h accountopt.h away.h blist.h buddyicon.h cmds.h config.h connection.h conversation.h core.h debug.h eventloop.h ft.h gaim.h imgstore.h log.h md5.h network.h notify.h plugin.h pluginpref.h pounce.h prefix.h prefs.h privacy.h proxy.h prpl.h request.h roomlist.h server.h sha.h signals.h sound.h sslconn.h status.h stringref.h util.h value.h version.h xmlnode.h
34         do
35                 if [ -e ${S}/src/$header ]; then
36                         install -m 0644 ${S}/src/$header $GAIM_DIR
37                 fi
38                 if [ -e ${S}/$header ]; then
39                         install -m 0644 ${S}/$header $GAIM_DIR
40                 fi
41         done
42 }
43
44 PACKAGES_DYNAMIC = "libgaim-protocol-*"
45
46 #FIXME: use do_packages to create individual packages for each of the plugins
47 python populate_packages_prepend () {
48         plugindir = bb.data.expand('${libdir}/gaim', d)
49         do_split_packages(d, plugindir, '^lib(.*)\.so$', 'libgaim-protocol-%s', 'GAIM plugin for %s protocol', extra_depends='' )
50 }
51
52 PACKAGES += "libgaim-plugins"
53 FILES_libgaim-plugins = "${libdir}/gaim/autorecon.so ${libdir}/gaim/s*.so"
54