update driver
[vuplus_openembedded] / recipes / qpe-gaim / qpe-gaim_20041030.bb
1 DESCRIPTION = "A multi protocol instant messager application, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 DEPENDS = "qpe-libgaim glib-2.0"
4 RDEPENDS = "libgaim-plugins glibc-gconv-iso8859-1"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
7 APPNAME = "gaim"
8 APPTYPE = "binary"
9 LICENSE = "GPL"
10 APPDESKTOP = "${S}"
11 PR = "r2"
12
13 SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
14            file://qpe-gaim.patch;patch=1 \
15            file://buzzer-notification.patch;patch=1;pnum=1 \
16            file://vit.patch;patch=1"
17 S = "${WORKDIR}/qpe-gaim"
18
19 inherit opie
20
21 EXTRA_QMAKEVARS_POST +="INCLUDEPATH-=${includedir}/glib-2.0 \
22                         INCLUDEPATH-=${libdir}/glib-2.0/include \
23                         INCLUDEPATH+=${STAGING_INCDIR}/glib-2.0 \
24                         LIBS-=-lopie LIBS+=-lopiecore2 LIBS+=-lopieui2"
25
26 do_configure_prepend() {
27         ln -s ../libgaim/src libgaim
28 }
29
30 do_install() {
31         for dir in 16x16 32x32 protocols status
32         do
33                 install -d ${D}${palmtopdir}/pics/gaim/${dir}
34                 install -m 0644 data/images/${dir}/*.png ${D}${palmtopdir}/pics/gaim/${dir}/
35         done
36         install -m 0644 gaim.png ${D}${palmtopdir}/pics/
37 }