increase dvbapp PR.
[vuplus_openembedded] / recipes / qemu / qemu_20070613.bb
1 LICENSE = "GPL"
2 DEPENDS = "zlib"
3 SRCDATE = "20070613"
4 PV = "0.9.0+cvs${SRCDATE}"
5 PR = "r5"
6
7 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
8 FILESDIR = "${WORKDIR}"
9
10 SRC_URI = "\
11     cvs://anonymous@cvs.savannah.nongnu.org/sources/qemu;method=pserver;rsh=ssh;module=qemu \
12     file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
13     file://03_machines_list_no_error.patch;patch=1;pnum=0 \
14     file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
15     file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
16     file://06_exit_segfault.patch;patch=1;pnum=0 \
17     file://10_signal_jobs.patch;patch=1;pnum=0 \
18     file://11_signal_sigaction.patch;patch=1;pnum=0 \
19     file://12_signal_powerpc_support.patch;patch=1;pnum=1 \
20     file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
21     file://31_syscalls.patch;patch=1;pnum=0 \
22     file://32_syscall_sysctl.patch;patch=1;pnum=0 \
23     file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
24     file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
25     file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
26     file://52_ne2000_return.patch;patch=1;pnum=1 \
27     file://61_safe_64bit_int.patch;patch=1;pnum=0 \
28     file://63_sparc_build.patch;patch=1;pnum=0 \
29     file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
30     file://65_kfreebsd.patch;patch=1;pnum=0 \
31     file://66_tls_ld.patch;patch=1;pnum=0 \
32     file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
33     file://93-oh-pl110-rgb.patch;patch=1;pnum=0 \
34     file://qemu-0.9.0-nptl.patch;patch=1 \
35     file://qemu-0.9.0-nptl-update.patch;patch=1 \
36     file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
37     file://workaround_bad_futex_headers.patch;patch=1 \
38     file://fix_segfault.patch;patch=1 \
39     file://no-strip.patch;patch=1"
40
41 S = "${WORKDIR}/qemu"
42
43 #EXTRA_OECONF = "--disable-sdl"
44 #EXTRA_OECONF = "--disable-gfx-check --target-list=arm-linux-user"
45 EXTRA_OECONF = "--disable-gfx-check"
46
47 inherit autotools
48