Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / qemu / qemu_0.9.1.bb
1 LICENSE = "GPL"
2 DEPENDS = "zlib"
3 PR = "r7"
4
5 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
6 FILESDIR = "${WORKDIR}"
7
8 SRC_URI = "\
9     http://www.bellard.org/qemu/qemu-0.9.1.tar.gz \
10     file://02_snapshot_use_tmpdir.patch;patch=1;pnum=0 \
11     file://04_do_not_print_rtc_freq_if_ok.patch;patch=1;pnum=1 \
12     file://05_non-fatal_if_linux_hd_missing.patch;patch=1;pnum=1 \
13     file://06_exit_segfault.patch;patch=1;pnum=0 \
14     file://10_signal_jobs.patch;patch=1;pnum=0 \
15     file://11_signal_sigaction.patch;patch=1;pnum=0 \
16     file://22_net_tuntap_stall.patch;patch=1;pnum=0 \
17     file://31_syscalls.patch;patch=1;pnum=0 \
18     file://32_syscall_sysctl.patch;patch=1;pnum=0 \
19     file://33_syscall_ppc_clone.patch;patch=1;pnum=0 \
20     file://39_syscall_fadvise64.patch;patch=1;pnum=0 \
21     file://41_arm_fpa_sigfpe.patch;patch=1;pnum=0 \
22     file://52_ne2000_return.patch;patch=1;pnum=1 \
23     file://61_safe_64bit_int.patch;patch=1;pnum=0 \
24     file://63_sparc_build.patch;patch=1;pnum=0 \
25     file://64_ppc_asm_constraints.patch;patch=1;pnum=1 \
26     file://65_kfreebsd.patch;patch=1;pnum=0 \
27     file://66_tls_ld.patch;patch=1;pnum=0 \
28     file://91-oh-sdl-cursor.patch;patch=1;pnum=0 \
29     file://qemu-0.9.0-nptl.patch;patch=1 \
30     file://qemu-0.9.0-nptl-update.patch;patch=1 \
31     file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
32     file://workaround_bad_futex_headers.patch;patch=1 \
33     file://fix_segfault.patch;patch=1 \
34     file://writev_fix.patch;patch=1 \
35     file://configure_symlinkpath_fix.patch;patch=1 \
36     file://disable-error-in-configure.patch;patch=1 \
37     file://no-strip.patch;patch=1"
38
39 S = "${WORKDIR}/qemu-${PV}"
40
41 #EXTRA_OECONF += "--disable-sdl"
42 #EXTRA_OECONF += "--target-list=arm-linux-user,arm-softmmu"
43 EXTRA_OECONF += "--disable-gfx-check"
44
45 inherit autotools
46
47 do_configure() {
48     oe_runconf
49 }