dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / python / python-vorbis_1.4.bb
1 DESCRIPTION = "Python Vorbis Bindings"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 DEPENDS = "libvorbis python-ogg"
6 SRCNAME = "pyvorbis"
7 PR = "ml0"
8
9 SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz \
10            file://disable-oggcheck.patch;patch=1"
11 S = "${WORKDIR}/${SRCNAME}-${PV}"
12
13 inherit distutils
14
15 do_configure_prepend() {
16         touch Setup
17         echo "ogg_libs = ogg" >>Setup
18         echo "ogg_lib_dir = ${STAGING_LIBDIR}" >>Setup
19         echo "ogg_include_dir = ${STAGING_INCDIR}" >>Setup
20         echo "vorbis_libs = vorbis vorbisfile vorbisenc" >>Setup
21         echo "vorbis_lib_dir = ${STAGING_LIBDIR}" >>Setup
22         echo "vorbis_include_dir = ${STAGING_INCDIR}" >>Setup
23 }