increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-twisted_8.2.0.bb
1 DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2 Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols                   \
3 (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4 HOMEPAGE = "http://www.twistedmatrix.com"
5 SECTION = "console/network"
6 PRIORITY = "optional"
7 LICENSE = "LGPL"
8 PR = "r3"
9
10 SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2 "
11 S = "${WORKDIR}/Twisted-${PV}"
12
13 inherit setuptools
14
15 PACKAGES += "\
16   ${PN}-zsh \
17   ${PN}-test \
18   ${PN}-protocols \
19   ${PN}-bin \
20   ${PN}-conch \
21   ${PN}-lore \
22   ${PN}-mail \
23   ${PN}-names \
24   ${PN}-news \
25   ${PN}-runner \
26   ${PN}-web \
27   ${PN}-words \
28   ${PN}-flow \
29   ${PN}-pair \
30   ${PN}-core \
31 "
32
33 PROVIDES += "\
34   twisted-zsh \
35   twisted-test \
36   twisted-protocols \
37   twisted-bin \
38   twisted-zsh \
39   twisted-test \
40   twisted-protocols \
41   twisted-bin \
42   twisted-conch \
43   twisted-lore \
44   twisted-mail \
45   twisted-names \
46   twisted-news \
47   twisted-runner \
48   twisted-web \
49   twisted-words \
50   twisted-flow \
51   twisted-pair \
52   twisted-core \
53 "
54
55 RDEPENDS = "python-core python-zopeinterface python-shell"
56
57 RDEPENDS_${PN} += "\
58   ${PN}-bin \
59   ${PN}-conch \
60   ${PN}-lore \
61   ${PN}-mail \
62   ${PN}-names \
63   ${PN}-news \
64   ${PN}-runner \
65   ${PN}-web \
66   ${PN}-words \
67 "
68
69 do_install_append() {
70         # remove some useless files before packaging
71         find ${D} -name "*.bat" -o -name "*.c" -o -name "*.h" -exec rm {} \;
72 }
73
74 ALLOW_EMPTY = "1"
75 FILES_${PN} = ""
76
77 FILES_${PN}-test = " \
78   ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
79   ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
80 "
81
82 FILES_${PN}-protocols = " \
83   ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/ \
84 "
85
86 FILES_${PN}-zsh = " \
87   ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
88   ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
89 "
90
91 FILES_${PN}-bin = " \
92   ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \
93   ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \
94 "
95
96 FILES_${PN}-conch = " \
97   ${bindir}/ckeygen \
98   ${bindir}/tkconch \
99   ${bindir}/conch \
100   ${bindir}/conchftp \
101   ${bindir}/cftp \
102   ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
103   ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch  \
104 "
105
106 FILES_${PN}-core = " \
107 ${bindir}/manhole \
108 ${bindir}/mktap \
109 ${bindir}/twistd \
110 ${bindir}/tap2deb \
111 ${bindir}/tap2rpm \
112 ${bindir}/tapconvert \
113 ${bindir}/tkmktap \
114 ${bindir}/trial \
115 ${bindir}/easy_install* \
116 ${bindir}/pyhtmlizer \
117 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
118 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
119 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
120 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
121 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
122 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
123 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
124 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
125 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
126 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
127 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
128 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
129 ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
130 ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
131 ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
132 ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
133 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
134 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
135 ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
136 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
137 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
138 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
139 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
140 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
141 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
142 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
143 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
144 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
145 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
146 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
147 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
148 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
149 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
150 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
151 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
152 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
153 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
154 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
155 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
156 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
157 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
158 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
159 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
160 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
161 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
162 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
163 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
164 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
165 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
166 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
167 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
168 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
169 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
170 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
171 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
172 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
173 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
174 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
175 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
176 ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
177 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
178 ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
179 ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
180 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
181 ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
182 ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
183 ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
184 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
185 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/*.py* \
186 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/*.py* \
187 "
188
189 FILES_${PN}-lore = " \
190 ${bindir}/bookify \
191 ${bindir}/lore \
192 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \
193 ${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \
194 "
195
196 FILES_${PN}-mail = " \
197 ${bindir}/mailmail \
198 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
199 ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
200 "
201
202 FILES_${PN}-names = " \
203 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
204 ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
205 "
206
207 FILES_${PN}-news = " \
208 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
209 ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
210 "
211
212 FILES_${PN}-runner = " \
213 ${libdir}/site-packages/twisted/runner/portmap.so \
214 ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
215 "
216
217 FILES_${PN}-web = " \
218 ${bindir}/websetroot \
219 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
220 ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
221 "
222
223 FILES_${PN}-words = " \
224 ${bindir}/im \
225 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
226 ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
227 "
228
229 FILES_${PN}-flow = " \
230 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_flow.py* \
231 ${libdir}/${PYTHON_DIR}/site-packages/twisted/flow \"
232
233 FILES_${PN}-pair = " \
234 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_pair.py* \
235 ${libdir}/${PYTHON_DIR}/site-packages/twisted/pair \
236 "
237
238 FILES_${PN}-dbg += " \
239 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
240 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
241 "
242
243 python populate_packages_prepend () {
244         rprovides = ''
245
246         for package in bb.data.getVar('PACKAGES', d, 1).split():
247                 tokens = package.split('-')
248                 if len(tokens) > 2:
249                         name = 'twisted-' + tokens[2]
250                         rprovides += ' '+name
251                         bb.data.setVar('RPROVIDES_' + package, name, d)
252
253         bb.data.setVar('RPROVIDES_append', rprovides, d)
254 }