increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-twisted_2.5.0.bb
1 DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
2 Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols                   \
3 (including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
4 HOMEPAGE = "http://www.twistedmatrix.com"
5 SECTION = "console/network"
6 PRIORITY = "optional"
7 LICENSE = "LGPL"
8 PR = "r9"
9
10 SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/2.5/Twisted-${PV}.tar.bz2 \
11            file://remove-zope-check.patch;patch=1"
12 S = "${WORKDIR}/Twisted-${PV}"
13
14 inherit distutils
15
16 PACKAGES += "\
17   ${PN}-zsh \
18   ${PN}-test \
19   ${PN}-protocols \
20   ${PN}-bin \
21   ${PN}-conch \
22   ${PN}-lore \
23   ${PN}-mail \
24   ${PN}-names \
25   ${PN}-news \
26   ${PN}-runner \
27   ${PN}-web \
28   ${PN}-words \
29   ${PN}-core \
30 "
31
32 RDEPENDS = "python-core python-zopeinterface"
33 RDEPENDS_${PN} += "\
34   ${PN}-bin \
35   ${PN}-conch \
36   ${PN}-lore \
37   ${PN}-mail \
38   ${PN}-names \
39   ${PN}-news \
40   ${PN}-runner \
41   ${PN}-web \
42   ${PN}-words \
43 "
44
45 ALLOW_EMPTY = "1"
46 FILES_${PN} = ""
47
48 FILES_${PN}-test = " \
49   ${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
50 "
51
52 FILES_${PN}-protocols = " \
53   ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/ \
54 "
55
56 FILES_${PN}-zsh = " \
57   ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zsh \
58   ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.* \
59 "
60
61 FILES_${PN}-bin = " \
62   ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols/_c_urlarg.so \
63   ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/cBanana.so \
64 "
65
66 FILES_${PN}-conch = " \
67   ${bindir}/ckeygen \
68   ${bindir}/tkconch \
69   ${bindir}/conch \
70   ${bindir}/conchftp \
71   ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_conch.py* \
72   ${libdir}/${PYTHON_DIR}/site-packages/twisted/conch  \
73 "
74
75 FILES_${PN}-core = " \
76 ${bindir}/manhole \
77 ${bindir}/mktap \
78 ${bindir}/twistd \
79 ${bindir}/tap2deb \
80 ${bindir}/tap2rpm \
81 ${bindir}/tapconvert \
82 ${bindir}/tkmktap \
83 ${bindir}/trial \
84 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*.py* \
85 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/__init__.py* \
86 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/notestplugin.py* \
87 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/testplugin.py* \
88 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_ftp.py* \
89 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_inet.py* \
90 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_manhole.py* \
91 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_portforward.py* \
92 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_socks.py* \
93 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_telnet.py* \
94 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_trial.py* \
95 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/dropin.cache \
96 ${libdir}/${PYTHON_DIR}/site-packages/twisted/application \
97 ${libdir}/${PYTHON_DIR}/site-packages/twisted/cred \
98 ${libdir}/${PYTHON_DIR}/site-packages/twisted/enterprise \
99 ${libdir}/${PYTHON_DIR}/site-packages/twisted/internet \
100 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
101 ${libdir}/${PYTHON_DIR}/site-packages/twisted/manhole \
102 ${libdir}/${PYTHON_DIR}/site-packages/twisted/persisted \
103 ${libdir}/${PYTHON_DIR}/site-packages/twisted/protocols\
104 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python\
105 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/timeoutqueue.py* \
106 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/filepath.py* \
107 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dxprofile.py* \
108 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/plugin.py* \
109 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/htmlizer.py* \
110 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/__init__.py* \
111 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dispatch.py* \
112 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/hook.py* \
113 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadpool.py* \
114 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/otp.py* \
115 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/usage.py* \
116 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/roots.py* \
117 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/versions.py* \
118 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/urlpath.py* \
119 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/util.py* \
120 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/components.py* \
121 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/logfile.py* \
122 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/runtime.py* \
123 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/reflect.py* \
124 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/context.py* \
125 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/threadable.py* \
126 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/rebuild.py* \
127 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/failure.py* \
128 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/lockfile.py* \
129 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/formmethod.py* \
130 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/finalize.py* \
131 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/win32.py* \
132 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/dist.py* \
133 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/shortcut.py* \
134 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zipstream.py* \
135 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/release.py* \
136 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/syslog.py* \
137 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/log.py* \
138 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/compat.py* \
139 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/zshcomp.py* \
140 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/procutils.py* \
141 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/text.py* \
142 ${libdir}/${PYTHON_DIR}/site-packages/twisted/python/_twisted_zsh_stub \
143 ${libdir}/${PYTHON_DIR}/site-packages/twisted/scripts/ \
144 ${libdir}/${PYTHON_DIR}/site-packages/twisted/spread/ \
145 ${libdir}/${PYTHON_DIR}/site-packages/twisted/tap/ \
146 ${libdir}/${PYTHON_DIR}/site-packages/twisted/trial/ \
147 ${libdir}/${PYTHON_DIR}/site-packages/twisted/__init__.py* \
148 ${libdir}/${PYTHON_DIR}/site-packages/twisted/_version.py* \
149 ${libdir}/${PYTHON_DIR}/site-packages/twisted/copyright.py* \
150 ${libdir}/${PYTHON_DIR}/site-packages/twisted/im.py* \
151 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugin.py* \
152 "
153
154 FILES_${PN}-lore = " \
155 ${bindir}/bookify \
156 ${bindir}/lore \
157 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_lore.py* \
158 ${libdir}/${PYTHON_DIR}/site-packages/twisted/lore \
159 "
160
161 FILES_${PN}-mail = " \
162 ${bindir}/mailmail \
163 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_mail.py* \
164 ${libdir}/${PYTHON_DIR}/site-packages/twisted/mail \
165 "
166
167 FILES_${PN}-names = " \
168 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_names.py* \
169 ${libdir}/${PYTHON_DIR}/site-packages/twisted/names \
170 "
171
172 FILES_${PN}-news = " \
173 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_news.py* \
174 ${libdir}/${PYTHON_DIR}/site-packages/twisted/news \
175 "
176
177 FILES_${PN}-runner = " \
178 ${libdir}/site-packages/twisted/runner/portmap.so \
179 ${libdir}/${PYTHON_DIR}/site-packages/twisted/runner\
180 "
181
182 FILES_${PN}-web = " \
183 ${bindir}/websetroot \
184 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_web.py* \
185 ${libdir}/${PYTHON_DIR}/site-packages/twisted/web\
186 "
187
188 FILES_${PN}-words = " \
189 ${bindir}/im \
190 ${libdir}/${PYTHON_DIR}/site-packages/twisted/plugins/twisted_words.py* \
191 ${libdir}/${PYTHON_DIR}/site-packages/twisted/words\
192 "
193
194 FILES_${PN}-dbg += " \
195 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/.debug \
196 ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/*/.debug \
197 "