enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / python / python-pysqlite2_2.4.0.bb
1 DESCRIPTION = "Python interface to SQLite 3"
2 SECTION = "devel/python"
3 PRIORITY = "optional"
4 LICENSE = "BSD"
5 DEPENDS = "sqlite3"
6 SRCNAME = "pysqlite"
7 PR = "ml2"
8
9 SRC_URI = "http://initd.org/pub/software/pysqlite/releases/2.4/${PV}/${SRCNAME}-${PV}.tar.gz \
10            file://fix-setup.patch;patch=1"
11 S = "${WORKDIR}/${SRCNAME}-${PV}"
12
13 inherit distutils
14
15 do_install_append() {
16     install -d ${D}${datadir}/doc/
17     mv ${D}${datadir}/pysqlite2-doc ${D}${datadir}/doc/${PN}
18 }
19
20 RDEPENDS = "\
21  python-datetime \
22  python-lang \
23  python-crypt \
24  python-io \
25  python-threading \
26  python-unittest \
27  python-zlib \
28 "
29
30 PACKAGES =+ "${PN}-tests"
31 FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/pysqlite2/test"
32 RDEPENDS_${PN}-tests = "${PN}"