increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-pymp3_0.3.4.bb
1 DESCRIPTION = "A Curses-based mp3 player. See http://damien.degois.info/PyMP3/"
2 SECTION = "console/multimedia"
3 PRIORITY = "optional"
4 RDEPENDS = "python-core python-curses python-pyid3lib python-mad python-ao"
5 LICENSE = "GPL"
6 PR = "r3"
7
8 SRC_URI = "http://www.vanille.de/mirror/PyMP3-0.3.4.tar.gz"
9 S = "${WORKDIR}/PyMP3-0.3.4"
10
11 inherit distutils-base
12
13 PY_FILES = "box_info.py layer.py sound_ctrl.py stack.py txt_tools.py"
14
15 do_install() {
16    install -d ${D}${libdir}
17    install -d ${D}${libdir}/${PYTHON_DIR}
18    install -d ${D}${libdir}/${PYTHON_DIR}/site-packages
19
20    for f in ${PY_FILES}
21    do
22       install -m 0644 $f ${D}${libdir}/${PYTHON_DIR}/site-packages/
23    done
24
25    install -d ${D}${bindir}
26    install -m 755 pymp3 ${D}${bindir}/
27 }
28
29 FILES_${PN} += " ${libdir}/${PYTHON_DIR}/site-packages/"