increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-pygobject_2.16.0.bb
1 DESCRIPTION = "Python GObject bindings"
2 SECTION = "devel/python"
3 LICENSE = "LGPL"
4 DEPENDS = "python-pygobject-native-${PV}"
5 PE = "1"
6 PR = "ml2"
7
8 MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
9
10 SRC_URI = "\
11   ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
12   file://generate-constants.patch;patch=1 \
13 "
14 S = "${WORKDIR}/pygobject-${PV}"
15
16 FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
17
18 inherit autotools distutils-base pkgconfig
19
20 # necessary to let the call for python-config succeed
21 export BUILD_SYS
22 export HOST_SYS
23
24 do_stage() {
25         autotools_stage_all
26         install -d ${STAGING_LIBDIR}/../share/pygobject/
27         cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
28         install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
29         cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
30 }
31
32 PACKAGES += "${PN}-lib"
33
34 RDEPENDS_${PN} += "python-textutils"
35
36 FILES_${PN} = "${libdir}/python*"
37 FILES_${PN}-lib = "${libdir}/lib*.so.*"
38 FILES_${PN}-dev += "${bindir} ${datadir}"
39 FILES_${PN}-dbg += "${libdir}/.debug"