enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / python / python-pygobject_2.14.2.bb
1 DESCRIPTION = "Python GObject bindings"
2 SECTION = "devel/python"
3 LICENSE = "LGPL"
4 DEPENDS = "python-pygobject-native"
5 PE = "1"
6 PR = "r3"
7
8 MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
9
10 SRC_URI = "\
11   ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
12   file://python-path.patch;patch=1 \
13   file://generate-constants.patch;patch=1 \
14 "
15 S = "${WORKDIR}/pygobject-${PV}"
16
17 FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
18
19 inherit autotools distutils-base pkgconfig
20
21 EXTRA_OECONF += '--with-python-includes="${STAGING_INCDIR}/.."'
22
23 do_stage() {
24         autotools_stage_all
25         install -d ${STAGING_LIBDIR}/../share/pygobject/
26         cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
27         install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
28         cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
29 }
30
31 FILES_${PN} = "${libdir}/python*"
32 FILES_${PN}-dev += "${datadir}/pygobject/xsl"