dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / python / python-pygame_1.8.1.bb
1 DESCRIPTION = "Python libSDL Bindings"
2 SECTION = "devel/python"
3 HOMEPAGE = "http://www.pygame.org"
4 LICENSE = "LGPL"
5 DEPENDS = "libsdl-x11 libsdl-image libsdl-mixer libsdl-net libsdl-ttf python-numeric"
6 DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'smpeg', d)}"
7 SRCNAME = "pygame"
8 PR = "ml4"
9
10 SRC_URI = "\
11   ftp://ftp.pygame.org/pub/pygame/${SRCNAME}-${PV}release.tar.gz \
12   file://Setup \
13 "
14 S = "${WORKDIR}/${SRCNAME}-${PV}release"
15
16 inherit distutils
17
18 do_configure_prepend() {
19         cat ${WORKDIR}/Setup >Setup
20         SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >>Setup
21         if [ '${ENTERPRISE_DISTRO}' != '1' ]; then
22                 echo "movie src/movie.c \$(SDL) \$(SMPEG) \$(DEBUG)" >>Setup
23         fi
24 }
25
26 do_stage() {
27         distutils_stage_all
28 }
29
30 RDEPENDS = "python-numeric"