increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-native_2.6.4.bb
1 require python.inc
2 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
3 PR = "${INC_PR}.2"
4
5 SRC_URI = "\
6   http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2;name=archive \
7   file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
8   file://04-default-is-optimized.patch;patch=1 \
9   file://05-enable-ctypes-cross-build.patch;patch=1 \
10   file://10-distutils-fix-swig-parameter.patch;patch=1 \
11   file://11-distutils-never-modify-shebang-line.patch;patch=1 \
12   file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
13   file://debug.patch;patch=1 \
14   file://nohostlibs.patch;patch=1 \
15 "
16 S = "${WORKDIR}/Python-${PV}"
17
18 SRC_URI[archive.md5sum] = "fee5408634a54e721a93531aba37f8c1"
19 SRC_URI[archive.sha256sum] = "dad8d5575144a210d5cc4fdbc40b8a26386e9cdb1ef58941bec0be02c7cb9d89"
20
21 inherit native
22
23 EXTRA_OEMAKE = '\
24   BUILD_SYS="" \
25   HOST_SYS="" \
26   LIBC="" \
27   STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
28   STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
29 '
30
31 do_stage_append() {
32         install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen
33 }