increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-gst_0.10.17.bb
1 DESCRIPTION = "Python Gstreamer bindings"
2 SECTION = "devel/python"
3 LICENSE = "LGPL"
4 DEPENDS = "gstreamer gst-plugins-base python-pygobject"
5
6 SRC_URI = "\
7   http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
8   file://python-path.patch;patch=1 \
9   file://import-gobject-instead-of-pygtk.patch;patch=1 \
10 "
11 S = "${WORKDIR}/gst-python-${PV}"
12
13 inherit autotools pkgconfig  distutils-base
14
15 require fix-path.inc
16
17 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
18
19 do_configure_prepend() {
20     #install all except libtool
21     rm -f ${S}/common/m4/libtool.m4
22     rm -f ${S}/common/m4/lt*.m4
23     install -d ${S}/m4
24     install -m 0644 ${S}/common/m4/*.m4 ${S}/m4/
25 }
26
27 do_stage() {
28         autotools_stage_all
29 }
30
31 PACKAGES =+ "${PN}-examples"
32
33 FILES_${PN} += "${datadir}/gst-python"
34 FILES_${PN}-dev += "\
35   ${datadir}/gst-python/0.10/defs \
36   ${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/*.la \
37 "
38 FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
39 FILES_${PN}-examples = "${datadir}/gst-python/0.10/examples"