increase dvbapp PR.
[vuplus_openembedded] / recipes / python / python-gst_0.10.10.bb
1 DESCRIPTION = "Python Gstreamer bindings"
2 SECTION = "devel/python"
3 LICENSE = "LGPL"
4 DEPENDS = "gstreamer gst-plugins-base python-pygobject"
5 PR = "ml4"
6
7 SRC_URI = "\
8   http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
9   file://python-path.patch;patch=1 \
10   file://import-gobject-instead-of-pygtk.patch;patch=1 \
11 "
12 S = "${WORKDIR}/gst-python-${PV}"
13
14 inherit autotools pkgconfig  distutils-base
15
16 require fix-path.inc
17
18 EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
19
20 do_configure_prepend() {
21     install -d ${S}/m4
22     install -m 0644 ${S}/common/m4/*.m4 ${S}/m4/
23 }
24
25 do_stage() {
26         autotools_stage_all
27 }
28
29 PACKAGES =+ "${PN}-examples"
30
31 FILES_${PN} += "${datadir}/gst-python"
32 FILES_${PN}-dev += "\
33   ${datadir}/gst-python/0.10/defs \
34   ${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/*.la \
35 "
36 FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/"
37 FILES_${PN}-examples = "${datadir}/gst-python/0.10/examples"