Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / puzzles / oh-puzzles_svn.bb
1 DESCRIPTION = "Portable Puzzle Collection"
2 LICENSE = "MIT"
3 SECTION = "x11"
4 DEPENDS = "gtk+ gconf intltool-native librsvg libowl"
5 PV = "0.1+svnr${SRCREV}"
6 PR = "r5"
7
8 inherit autotools pkgconfig
9
10 SRC_URI = "svn://svn.o-hand.com/repos/;module=oh-puzzles;proto=http"
11 S = "${WORKDIR}/${PN}"
12
13 do_install_append() {
14     mv ${D}${bindir} ${D}/usr/games
15
16     install -d ${D}/${datadir}/applications/
17
18     cd ${D}/${prefix}/games
19     for prog in *; do
20         if [ -x $prog ]; then
21             # Convert prog to Title Case
22             title=$(echo $prog | sed 's/\(^\| \)./\U&/g')
23             echo "making ${D}/${datadir}/applications/$prog.desktop"
24             cat <<STOP > ${D}/${datadir}/applications/$prog.desktop
25 [Desktop Entry]
26 Encoding=UTF-8
27 Name=$title
28 Exec=${prefix}/games/$prog
29 Icon=applications-games
30 Terminal=false
31 Type=Application
32 Categories=Game
33 StartupNotify=true
34 SingleInstance=true
35 Comment=Play $title.
36 STOP
37         fi
38     done
39 }
40
41 FILES_${PN} += "${prefix}/games/*"
42 FILES_${PN}-dbg += "${prefix}/games/.debug/*"
43