increase dvbapp PR.
[vuplus_openembedded] / recipes / putty / putty_svn.bb
1 DESCRIPTION = "PuTTY is a free implementation of Telnet and SSH for Win32 and Unix platforms"
2 SECTION = "console/network"
3 LICENSE = "MIT"
4 #Remove the dash below when 0.58 changes in PV
5 PV = "0.58+cvs-${SRCDATE}"
6
7 SRC_URI = "svn://ixion.tartarus.org/main;module=putty \
8            file://lib.pro \
9            file://plink.pro \
10            file://pscp.pro \
11            file://psftp.pro"
12
13 TARGETS = "lib plink pscp psftp"
14
15 S = "${WORKDIR}/putty"
16
17 inherit qmake_base
18
19 do_configure() {
20         for t in ${TARGETS}
21         do
22                 install -m 0644 ${WORKDIR}/$t.pro .
23         done
24         cd charset && perl sbcsgen.pl
25 }
26
27 do_compile() {
28         for t in ${TARGETS}
29         do
30                 rm -f Makefile
31                 qmake -makefile -o Makefile -spec ${QMAKESPEC} $t.pro
32                 oe_runmake
33         done
34 }
35
36 do_install() {
37         install -d ${D}${libdir}
38         oe_libinstall -so libputty ${D}${libdir}
39         install -d ${D}${bindir}/
40         install -m 0755 plink ${D}${bindir}/ssh
41         install -m 0755 pscp ${D}${bindir}/scp
42         install -m 0755 psftp ${D}${bindir}/sftp
43 }
44