change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / pulseaudio / pulseaudio_0.9.11.bb
1 require pulseaudio.inc
2
3 DEPENDS += "gdbm speex"
4 PR = "${INC_PR}.1"
5
6 # work in progress
7 DEFAULT_PREFERENCE = "-1"
8
9 SRC_URI += "\
10   file://disable-using-glibc-tls.patch;patch=1 \
11   file://buildfix.patch;patch=1 \
12 #  file://libpulsedsp-references-libpulsecore.patch;patch=1 \
13 #  file://pa-drop-caps-returns-void.patch;patch=1 \
14 #  file://libtool2.patch;patch=1 \
15   file://2113.diff;patch=1;pnum=0 \
16   file://2114.diff;patch=1;pnum=0 \
17 #  file://libiconv.patch;patch=1 \
18 "            
19
20 do_compile_prepend() {
21     cd ${S}
22     mkdir -p ${S}/libltdl
23     cp ${STAGING_LIBDIR}/libltdl* ${S}/libltdl
24 }
25
26
27 # problems w/ pulseaudio 0.9.10 atm:
28 # 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
29 # 2.) doesn't build w/ glibc TLS support (hence patched out)
30 # 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out)
31