Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / pulseaudio / pulseaudio_0.9.10.bb
1 require pulseaudio.inc
2
3 PR = "${INC_PR}.1"
4
5 SRC_URI += "\
6   file://disable-using-glibc-tls.patch;patch=1 \
7   file://libpulsedsp-references-libpulsecore.patch;patch=1 \
8   file://pa-drop-caps-returns-void.patch;patch=1 \
9 #  file://libtool2.patch;patch=1 \
10   file://2113.diff;patch=1;pnum=0 \
11   file://2114.diff;patch=1;pnum=0 \
12   file://libiconv.patch;patch=1 \
13 "            
14
15 do_compile_prepend() {
16     cd ${S}
17     mkdir -p ${S}/libltdl
18     cp ${STAGING_LIBDIR}/libltdl* ${S}/libltdl
19 }
20
21
22 # problems w/ pulseaudio 0.9.10 atm:
23 # 1.) needs libltdl >= 1.5.24 (yes, any older version will NOT work at runtime)
24 # 2.) doesn't build w/ glibc TLS support (hence patched out)
25 # 3.) fails with hierarchical pthread stuff w/ gst-pulse (hence patched out)
26