increase dvbapp PR.
[vuplus_openembedded] / recipes / pulseaudio / libcanberra_0.14.bb
1 DESCRIPTION = "Libcanberra is an implementation of the XDG Sound Theme and Name \
2 Specifications, for generating event sounds on free desktops."
3 LICENSE = "LGPL"
4 DEPENDS = "alsa-lib gstreamer gtk+ libvorbis pulseaudio"
5 SECTION = "libs/multimedia"
6 AUTHOR = "Lennart Poettering"
7 HOMEPAGE = "http://0pointer.de/lennart/projects/libcanberra"
8 PR = "r2"
9
10 inherit autotools_stage
11 AUTOTOOLS_STAGE_PKGCONFIG = "1"
12
13 SRC_URI = "http://0pointer.de/lennart/projects/libcanberra/libcanberra-${PV}.tar.gz \
14            file://libcanberra-increase-buffer-size.patch;patch=1"
15
16 EXTRA_OECONF = "\
17   --enable-alsa \
18   --enable-gstreamer \
19   --enable-gtk \
20   --enable-multi \
21   --enable-null \
22   --disable-oss \
23 # enable pulse again when pulseaudio >= 0.9.11 is the default in OE
24   --disable-pulse \
25   --disable-tdb \
26 "
27
28 # This needs autoconf 2.62, which isn't used by any distro in OE atm
29 do_configure() {
30         gnu-configize --force
31         oe_runconf
32 }
33
34 # TODO: Test more fine granular version
35 #OE_LT_RPATH_ALLOW=":${libdir}/${P}:"
36 OE_LT_RPATH_ALLOW = "any"
37 OE_LT_RPATH_ALLOW[export] = "1"
38
39 python populate_packages_prepend() {
40         plugindir = bb.data.expand('${libdir}/${P}/', d)
41         do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' )
42 }
43
44 PACKAGES =+ "${PN}-gtk"
45
46 PACKAGES_DYNAMIC = "libcanberra-*"
47
48 FILES_${PN}-gtk = "\
49   ${sysconfdir}/gconf \
50   ${bindir}/* \
51   ${libdir}/libcanberra-gtk.so.* \
52   ${libdir}/gtk-2.0/modules/* \
53   ${datadir}/gnome \
54 "
55 FILES_${PN}-dev += "\
56   ${libdir}/${P}/*.la \
57 "
58 FILES_${PN}-dbg += "\
59   ${libdir}/gtk-2.0/modules/.debug \
60   ${libdir}/${P}/.debug \
61 "