Merge commit 'oe/org.openembedded.dev' into opendreambox
[vuplus_openembedded] / recipes / pth / pth_2.0.2.bb
1 DESCRIPTION = "GNU Portable Threads"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL FDL"
5 PR = "r2"
6
7 SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
8            file://m4-warning.patch;patch=1 \
9            file://ldflags.patch;patch=1 \
10           "
11
12 PARALLEL_MAKE=""
13
14 inherit autotools
15
16 do_configure() {
17         gnu-configize
18         oe_runconf
19 }
20
21 do_stage() {
22         oe_libinstall -so libpth ${STAGING_LIBDIR}
23
24         install -d ${STAGING_INCDIR}/
25         for X in pth.h
26         do
27                 install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
28         done
29
30         install -d ${STAGING_DATADIR}/aclocal
31         install pth.m4 ${STAGING_DATADIR}/aclocal/
32 }