increase dvbapp PR.
[vuplus_openembedded] / recipes / proftpd / proftpd_1.3.2b.bb
1 DESCRIPTION = "Secure ftp daemon"
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 PR = "r0"
5
6 SRC_URI = "ftp://ftp.nl.uu.net/pub/unix/ftp/proftpd/ftp/distrib/source/${PN}-${PV}.tar.gz \
7         file://make.patch;patch=1 \
8         "
9
10
11 EXTRA_OECONF = "ac_cv_func_setpgrp_void=yes ac_cv_func_setgrent_void=yes"
12 LDFLAGS += "-Llib"
13 PARALLEL_MAKE = ""
14
15 do_configure () {
16          ./configure \
17                    --disable-auth-pam \
18                    --build=${BUILD_SYS} \
19                    --host=${HOST_SYS} \
20                    --target=${TARGET_SYS} \
21                    --prefix=/usr \
22                    --sysconfdir=/etc \
23                    --sharedstatedir=/com \
24                    --localstatedir=/var \
25                    ${EXTRA_OECONF} \
26                    $@;
27 }
28
29 do_install () {
30         oe_runmake DESTDIR=${D} install
31 }
32
33 pkg_postinst () {
34         # more chown's might be needed
35         chown root:root /usr/sbin/proftpd
36 }